Author Topic: !! Solucion a VAM en 1adn1 !!  (Read 2334 times)

otomas

  • Newbie
  • *
  • Posts: 11
    • View Profile
!! Solucion a VAM en 1adn1 !!
« on: August 07, 2016, 09:46:51 PM »
buenas a todos
hace meses intente una instalacion en un hosting que tengo en 1and1 pero fue un fracaso y lo deje correr... :-[
Esta tarde, aburrido ( estoy de vacas), me decidi a buscar el porque del problema... ???
Pues bien, ya tengo el vam funcionando correctamente, mas precisamente la parte de administracion (que he leido que ha dado mas de un quebradero de cabeza a mas de uno) y sin fallos de ningun tipo
Aqui mi granito de arena...

1. primero problema relacionado con las fechas....
Strict Standards: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /homepages/37/d525148850/htdocs/vam/vamcore/lib/Cake/Cache/CacheEngine.php on line 60

pues bien, editamos el fichero vam/vamcore/lib/Cake/Cache/CacheEngine.php vamos a la linea 59 y tenemos
               
                if (!is_numeric($this->settings['duration'])) {
         date_default_timezone_set('Europe/Berlin');
         $this->settings['duration'] = strtotime($this->settings['duration']) - time();
      }
despues de la linea 59 añadimos esta linea
                       date_default_timezone_set('Europe/Berlin');

con lo que nos queda :

                if (!is_numeric($this->settings['duration'])) {
         date_default_timezone_set('Europe/Berlin');
         $this->settings['duration'] = strtotime($this->settings['duration']) - time();
      }

en mi caso, los dos stricts han desaparecido...

2 paso que la parte de administracion de vea como la diseñaron...
!! OJO HACED UNA COPIA DE TODO ANTES DE MODIFICAR!!!!!!

decir que no soy un experto en administracion web y que he ido leyendo sobre el .httaccess que es el responsable en cierta forma que los "objetos" se vean bien...
2a......En la carpeta principal del VAM tenemos que crear un .htaccess que contendra :
            <IfModule mod_rewrite.c>
                       RewriteEngine On
                  RewriteBase /vamcore/
                       RewriteBase /vamcore/app/
                       RewriteBase /vamcore/app/webroot/
                       RewriteCond %{REQUEST_FILENAME} !-d
                       RewriteCond %{REQUEST_FILENAME} !-f
                       RewriteRule ^(.*)$ index.php [QSA,L]
</IfModule>


cuando antes no nos aparecia nada, ahora ya vemos una lista...

2b.......En la carpeta VAMCORE editamos el fichero .htaccess
                    <IfModule mod_rewrite.c>
                              RewriteEngine on
                              RewriteBase /vamcore/
                              RewriteRule (.*) app/webroot/$1 [L]
                    </IfModule>
aqui ya vemos los modulos....
y todos funcionado..

pues nada aqui lo dejo para que sirva a quien como yo ha sentido deseos de mandarlo todo a la M... ;D ;D ;D


« Last Edit: August 17, 2016, 11:46:37 PM by VAM »

VAM

  • Administrator
  • Hero Member
  • *****
  • Posts: 1328
    • View Profile
    • virtual Airlines Manager
Re: !! Solucion a VAM en 1adn1 !!
« Reply #1 on: August 17, 2016, 11:45:37 PM »
buenas a todos
hace meses intente una instalacion en un hosting que tengo en 1and1 pero fue un fracaso y lo deje correr... :-[
Esta tarde, aburrido ( estoy de vacas), me decidi a buscar el porque del problema... ???
Pues bien, ya tengo el vam funcionando correctamente, mas precisamente la parte de administracion (que he leido que ha dado mas de un quebradero de cabeza a mas de uno) y sin fallos de ningun tipo
Aqui mi granito de arena...

1. primero problema relacionado con las fechas....
Strict Standards: strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /homepages/37/d525148850/htdocs/vam/vamcore/lib/Cake/Cache/CacheEngine.php on line 60

pues bien, editamos el fichero vam/vamcore/lib/Cake/Cache/CacheEngine.php vamos a la linea 59 y tenemos
               
                if (!is_numeric($this->settings['duration'])) {
         date_default_timezone_set('Europe/Berlin');
         $this->settings['duration'] = strtotime($this->settings['duration']) - time();
      }
despues de la linea 59 añadimos esta linea
                       date_default_timezone_set('Europe/Berlin');

con lo que nos queda :

                if (!is_numeric($this->settings['duration'])) {
         date_default_timezone_set('Europe/Berlin');
         $this->settings['duration'] = strtotime($this->settings['duration']) - time();
      }

en mi caso, los dos stricts han desaparecido...

2 paso que la parte de administracion de vea como la diseñaron...
!! OJO HACED UNA COPIA DE TODO ANTES DE MODIFICAR!!!!!!

decir que no soy un experto en administracion web y que he ido leyendo sobre el .httaccess que es el responsable en cierta forma que los "objetos" se vean bien...
2a......En la carpeta principal del VAM tenemos que crear un .htaccess que contendra :
            <IfModule mod_rewrite.c>
                       RewriteEngine On
                  RewriteBase /vamcore/
                       RewriteBase /vamcore/app/
                       RewriteBase /vamcore/app/webroot/
                       RewriteCond %{REQUEST_FILENAME} !-d
                       RewriteCond %{REQUEST_FILENAME} !-f
                       RewriteRule ^(.*)$ index.php [QSA,L]
</IfModule>


cuando antes no nos aparecia nada, ahora ya vemos una lista...

2b.......En la carpeta VAMCORE editamos el fichero .htaccess
                    <IfModule mod_rewrite.c>
                              RewriteEngine on
                              RewriteBase /vamcore/
                              RewriteRule (.*) app/webroot/$1 [L]
                    </IfModule>
aqui ya vemos los modulos....
y todos funcionado..

pues nada aqui lo dejo para que sirva a quien como yo ha sentido deseos de mandarlo todo a la M... ;D ;D ;D

Muchas gracias por este pedazo aporte, se nota que le has dedicado horas :-) Yo ya daba por imposible el usar 1&1 con VAM, aunque es verdad que nunca lo he probado directamente pues no tengo cuenta en 1&1. Voy a traducir esto al ingles para que lo puedan usar los extranjeros y de paso pongo este post con una chincheta.
Gracias!
VAM Creator and programmer.

otomas

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: !! Solucion a VAM en 1adn1 !!
« Reply #2 on: August 25, 2016, 04:30:58 PM »
nada hombre, para todo aquel al que le pueda ser util
y es el fruto de la PASION que le pongo al tema y al ser "informatico de pasion y profesion" pues eso en todo los que pueda cuenta conmigo