Author Topic: New version  (Read 364 times)

rsantosf

  • Newbie
  • *
  • Posts: 7
    • View Profile
New version
« on: August 02, 2020, 11:50:58 PM »
Hi!

I have updated the VAM files so that it is now compatible with new versions of the databases.

You can read the full article here (spanish):

https://www.rafaelsantos.es/web/aficiones/simuladores-de-vuelo/67-vam-virtual-airlines-manager-actualizado-para-mysql-5-7-o-superior

I hope you like it.

Sophie

  • Full Member
  • ***
  • Posts: 135
    • View Profile
Re: New version
« Reply #1 on: August 04, 2020, 05:06:39 PM »
Thank you. That sounds very good.
Currently, I am afraid that the VAM system will not work anymore when switching to Microsoft 2020,
because we do not get any source code from the developer to make adjustments. 
The ACARS will not recognize the new simulator.

But for all those who don't change, this is a very good update ! 

Thanks
Please use the search function, this will help you with most of the questions asked here.

rsantosf

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: New version
« Reply #2 on: August 05, 2020, 03:31:49 PM »
I hope that the ACARS's creator share the source code. I would try update it if it's possible.

I don't mind it, I'd do it.


ebfelix

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: New version
« Reply #3 on: August 17, 2020, 02:55:31 AM »
Hi Rafael, how are you ?

Please may you inform if this version are compatible with PHP 7? 

Since some servers don't have option to change PHP version for one application specially, in my case, I've running moodle as flight school with PHP 7.4, and don't have a way to choose PHP 5.6 to run VAM.

In addition, I'm having problems with https and SIMACARS, etc... that I'm wondering is PHP related.
Thanks in advance.

E. Felix
www.fsbrasil.com

x-george

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: New version
« Reply #4 on: August 18, 2020, 08:02:01 AM »
ebfelix, On 7.2 works

rsantosf

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: New version
« Reply #5 on: August 22, 2020, 07:37:57 PM »
This version is tested on PHP 7.4.9 and MySQL 8. All with HTTPS.
In any case, I advise first to do some tests in different directories. Just in case. It depends a lot on the PHP.ini settings of the servers and not all installations have all the libraries.

I add one thing more:

This version is compatible with FSUIPC 7 with FS2020

You only need to download the new FSUIPC:

https://forum.simflight.com/topic/90193-fsuipc7-beta-for-msfs/

Regards.

drgullen

  • Full Member
  • ***
  • Posts: 166
    • View Profile
Re: New version
« Reply #6 on: August 23, 2020, 08:30:06 AM »
This is great work but now we need someone to get in touch with Alejandro and convince him to release the source code for SIM ACARS so that we can add functionality for FS 2020 to that and then we'd have one ACARS program that connects to them all.

Is anyone here a close friend/contact of Alejandro?  He has been absent for a while now -- it's a shame to not continue on with SIM ACARS.  I would be happy to work on it if given the source code, so if someone can get him on here to get his opinions/plans/ideas about the future of VAM and SIM ACARS, please contact him and ask him to log onto the forum.

jiko

  • Newbie
  • *
  • Posts: 18
    • View Profile
Re: New version
« Reply #7 on: August 24, 2020, 09:05:21 PM »
drgullen +1

ebfelix

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: New version
« Reply #8 on: September 04, 2020, 06:08:59 PM »
Rafael,


Thank you for the great work, just testing in parallel directory, and works with PHP 7.4 and FSUIPC. Related https problems solved, and now I'll work on template, since we have historic layout the old pilots here are conditioned.

Thanks a lot !

E. Felix
www.fsbrasil.com

VBD201

  • Full Member
  • ***
  • Posts: 109
    • View Profile
Re: New version
« Reply #9 on: September 08, 2020, 07:04:09 PM »
I have changed but in the administrator control panel I get the error below
Warning (2): preg_match(): Compilation failed: invalid range in character class at offset 4 [CORE/Cake/Model/Datasource/DboSource.php, line 850]
Warning (2): preg_match(): Compilation failed: invalid range in character class at offset 4 [CORE/Cake/Model/Datasource/DboSource.php, line 850]
Notice (8): compact(): Undefined variable: subject [CORE/Cake/Utility/ObjectCollection.php, line 128]
Notice (8): compact(): Undefined variable: subject [CORE/Cake/Utility/ObjectCollection.php, line 128]
Notice (8): compact(): Undefined variable: subject [CORE/Cake/Utility/ObjectCollection.php, line 128]