Author Topic: new installation  (Read 271 times)

PilotRainer

  • Newbie
  • *
  • Posts: 1
    • View Profile
new installation
« on: January 20, 2019, 08:24:25 PM »
« Last Edit: January 21, 2019, 03:11:18 PM by PilotRainer »

Sim00n

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: new installation
« Reply #1 on: February 26, 2019, 01:21:20 PM »
I'd like to echo OP's problem.
I'm suspecting the issue (both his and mine) has something to do with the .htaccess file in the administrator directory.

From what I've been able to tell, the administrator section is written using CakePHP and requires some re-writes.

I'm using Nginx instead of Apache and therefor .htaccess doesn't work. Could one of the creators of VAM please provide an Nginx configuration to make VAM work?
I've tried all kinds of CakePHP recommended redirects but somehow still get "Access denied" sort of error (via PHP, not the web server).

Help will be appreciated.

// EDIT

With the help of another post and more tinkering, I was able to figure out Nginx rewrites that I think work:
Code: [Select]
location /vamcore/ {
rewrite ^/vamcore/$ /vamcore/app/webroot/ break;
rewrite ^/vamcore/css/(.*)$ /vamcore/app/webroot/css/$1 break;
rewrite ^/vamcore/files/(.*)$ /vamcore/app/webroot/files/$1 break;
rewrite ^/vamcore/img/(.*)$ /vamcore/app/webroot/img/$1 break;
rewrite ^/vamcore/js/(.*)$ /vamcore/app/webroot/js/$1 break;
rewrite ^/vamcore/favicon.ico$ /vamcore/app/webroot/favicon.ico break;


rewrite ^/vamcore/(.*)$ /vamcore/app/webroot/index.php?url=$1;

location ~ \.php$ {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
}

}
« Last Edit: February 26, 2019, 03:36:26 PM by Sim00n »