Author Topic: Install errors  (Read 166 times)

cyberserenity

  • Newbie
  • *
  • Posts: 1
    • View Profile
Install errors
« on: May 03, 2017, 12:25:23 PM »
Installing 2.6.2
SQL script errors
VARCHAR to big in db_schema.sql stops install

allow_select_aircraft_for_charter not in db_data_2.sql line 20799. I just put it in and gave it value 1.

SQL error when trying to edit pilot. But admin pages work for same thing.

What i found so far. But scripts have to work or install does not work. MySQL server 5.6.35 on OpenSUSE

Other. Very nice software.

adanesh

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Install errors
« Reply #1 on: July 17, 2017, 06:01:23 AM »
I had similar issues in my environment (Mysql 5.7 + PHP 7 on Ubuntu Xenial):

- Invalid date/time default values on datetime fields -- I adjusted default values to be within in allowed range or set to CURRENT_TIMESTAMP
- VARCHAR fields with lengths too long -- I changed fields to TEXT fields
- Same error in db_data_2.sql re allow_select_aircraft_for_charter -- I set a default value for the field in the schema to address this

But, once installed I have faced other errors in the application with a range of SQL errors getting thrown in other locations in the administration tools particularly. Usually these have been down to missing default values on fields specified with NOT NULL where INSERTs are being done in the code without specifying values for these fields.

Am I the only one seeing these sorts of issues?

adanesh

  • Newbie
  • *
  • Posts: 15
    • View Profile
Re: Install errors
« Reply #2 on: July 22, 2017, 12:04:46 PM »
Is anyone else seeing these sorts of issues?