Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - cristian79652

Pages: [1] 2
1
Bug reports / Rank Settings
« on: April 24, 2020, 05:12:40 AM »
It works properly, but I would like the following would be possible:

I want a Pilot to pass an exam when he/she reaches the minimum hours for next rank.
I would like the rank would not change automatically letting he/she stay with the same rank til the moment of doing the exam.

I've tried:

rank1 min 0h / max 50h
rank2 min 40h / max 100h
(letting to continue flying 10 hours at rank1 without doing the exam, but didn't work, when he/she does 40h the rank automatically changes)

I wouldn't mind if I had to change ranks manually as required, cos I guess is easier to "disable" the automatic changes than creating php codes to do the work.

Could anyone tell me which is the file linked to this?

Thanks in advance!

2
Hi there!

I looked up posts related to the posibility to upload files to VAM, like an Airline Operation Manual.pdf so that your pilots could download them from Pilot Actions / Download section.

Is this already posible?

If  it's not... I could upload a file to some host but then how could I introduce the link in that section?

Thanks in advance

3
Soporte para Instalaciones / Re: Problema con la vista de la web
« on: March 19, 2020, 02:33:14 AM »
Está resuelto!
Veam mi post en la sección de inglés llamado "view issue"

Espero les sirva.

4
Support for Installation / Re: View issue
« on: March 19, 2020, 02:32:04 AM »
SOLVED!!!!!!

This were my key errors:

1   The first host I tried was on web default config PHP v 7.3. (This can be changed on the cpanel software opt. Which was very difficult to find) So, it must be changed to 7.0 solving the view issue of the website.

2   The same host had a limmited amount of tables to import at phpmyadmin, but had no message to advise me that of that, I just discovered it when I read the details of my host plan. (So some tables were missing and making VAM not towork at 100% once u log in) Nothing to do about it but look for another free host to prove VAM or upgrade your plan to get a bigger limmit of tables.

3   When I started trying on another host, I did all again but this time, the host's default name was not "localhost" as in the first one. So I had to change the first item in the db_login.php and database.php files.

                Database/Mysql',
      'persistent' => false,
      'host' => 'localhost',    <=had another name on the second host
      'login' => '****',
      'password' => '***',
      'database' => '***',
      'encoding' => 'utf8'

Thank you a lot Sophie!

5
Support for Installation / Re: View issue
« on: March 18, 2020, 11:45:24 PM »
Thank u a lot. I've discovered that the host may limmited the amout of tables.
It was difficult to find another but  I got one.
This time there was no problems importing sql files and now i see the table missing.
Once I finish uploading the files, I'll let you know if everything is OK.
I really appreciate your help!

6
Support for Installation / Re: View issue
« on: March 18, 2020, 08:34:59 PM »
I changed finally the version of PHP, it was 7.2 and set it to 7.0.
The msg at the top of the web, dissapeared!

Issues remaining:
At the bottom of the page:

1       "WELCOME TO
There was an error running the query [table 'id12936486_caratula.web_configurations' doesn't exist]"
Do you have this mentioned table on your database? Because i dont and that would be an evidence that sql files are not importing well.

2        Clicking on Register: Currently there is no vacancy in our company. Stay tuned for new recruitment process.

3        Following the steps of the video Tutorial, firs I must creat a HUB (done), then I must change administrator password (done), and then I must create the VA parameters, when i go inside that section, the icon to edit and view are not shown on the final column that is called "action". Watch this video on minute 1:00.
/>
Compare with mine at :     https://ibb.co/Cvnvhfw

7
Support for Installation / Re: View issue
« on: March 18, 2020, 07:45:37 PM »
Some infomation on PHP my admin info section

*** Which PHP versions does phpMyAdmin support?

Since release 4.5, phpMyAdmin supports only PHP 5.5 and newer. Since release 4.1 phpMyAdmin supports only PHP 5.3 and newer. For PHP 5.2 you can use 4.0.x releases.

PHP 7 is supported since phpMyAdmin 4.6, PHP 7.1 is supported since 4.6.5, PHP 7.2 is supported since 4.7.4.

phpMyAdmin also works fine with HHVM.

How do I go back to 4.6 version of PHP my admin? It only depends on the host?

8
Support for Installation / Re: View issue
« on: March 18, 2020, 07:40:14 PM »
Yes!!! I found it:

Servidor web

    Apache
    Versión del cliente de base de datos: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    extensión PHP: mysqliDocumentación curlDocumentación mbstringDocumentación
    Versión de PHP: 7.3.12

What should I do? Move to another host using 7.0 or 7.1? Or can I downgrade the version in some way to make it compatible?

9
Support for Installation / Re: View issue
« on: March 18, 2020, 07:36:52 PM »
Pls try an compleate new installation ..... not an update or Hotfix or somthing like that , download the latest version from Homepage.

This is inkl all Updates.

-----------------------------------------------------------

The view issue ....

vam_header.php

and

vam_index_header.php

change all http to https   http://prntscr.com/rik9fh

-----------------------------------------------------------------------------

But the really most important , dont use PHP  higher than 7.2

The System ist ist developed for 7.0 , but 7.1 works also fine. In some cases smal changes have to be made in 7.2, after that 7.2 will also work perfect.

My Setup

Server-Typ: MariaDB

Server-Version: 10.1.41-MariaDB

Database Clint Version: mysqlnd 5.0.12  is installed at my Webserver with Apache 2.4.29, with this setup you will have defenetly no Problems.

In a few cases "cheap hosters" have problems with mod_secure. Then you have to put your domain on the whitelist.

The errors you have posted are due to an incompatible database version. Here, the "small" modifications mentioned above are necessary to make it work.


Sophie

1        Thank u Sophie, I will rename all the http to https as u say on the header and index header.

2       When u say... dont use PHP  higher than 7.2, you refer to the Web server's version of PHP?

10
Support for Installation / Re: View issue
« on: March 18, 2020, 06:58:49 PM »
Importing to phpmyadmin "db_schema.sql"
The Tables were created but this msg appears:

Error
consulta SQL:

-- NEW TABLE FOR WEB SECTION CONFIGURATION
CREATE TABLE `web_configurations` (
  `id` INT NOT NULL AUTO_INCREMENT,
  `last_update` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP,
  `welcome_text` VARCHAR(30000) NULL,
  `rules` VARCHAR(60000) NULL,
  PRIMARY KEY (`id`)
) ENGINE = MyISAM CHARACTER SET utf8 COLLATE utf8_general_ci

MySQL ha dicho: Documentación
#1074 - Longitud de columna demasiado grande para la columna 'welcome_text' (maximo = 21844).Usar BLOB en su lugar
Translated would be
#1074 - Length of column too big for column 'welcome_text' (maximo = 21844).Use BLOB instead.

====================
Importing to phpmyadmin "db_data_2.sql"
consulta SQL:

Error
consulta SQL:

--
-- Data for table `va_parameters`
--

INSERT INTO `va_parameters` (`va_parameters_id`, `number_pilots`, `ivao`, `vatsim`, `va_icao`, `va_name`, `jump_type1`, `jump_type2`, `jump_type3`, `pirep_manual`, `pirep_fskeeper`, `pirep_fsacars`, `pirep_kacars`, `plane_status_hangar`, `landing_crash`, `landing_penalty1`, `landing_penalty2`, `landing_penalty3`, `landing_vs_penalty1`, `landing_vs_penalty2`, `flight_wear`, `hangar_maintenance_days`, `hangar_maintenance_value`, `hangar_crash_days`, `hangar_crash_value`, `pilot_crash_penalty`, `charter_reduction`, `currency`) VALUES
(1, 50, 1, 1, 'VAM', 'VAM Airlines', 100, 250, 500, 1, 1, 1, 0, 75, 850, 3, 6, 10, 200, 350, 5, 2, 6000, 8, 90000, 500, 50, 'eur')

 MySQL ha dicho: Documentación
#1364 - Field 'allow_select_aircraft_for_charter' doesn't have a default value

========================
No issues importing  "db_data_1 , 3, 4 and 5.sql"

Can someone upload their own installed .sql files so I make a try importing theme? May be mine are missing data.
On the video tutorial, it says that file "db_script_to_upgrade_from_VAM_2.5.2" is only imported when an already version of VAM is currently working. Should I try importing this file too?, Should I try doing it before importing "db_schema.sql"?

11
Support for Installation / Re: View issue
« on: March 18, 2020, 06:41:27 PM »
I followed every step on the tutorial, the only file modified is the one where I set my database user, which is working well. So, I don't know why have this issues with codes.
I remember there was an advisory while uploading some "db_data_number.sql", so i will do the import to those files again and will share the message.

12
Support for Installation / Re: View issue
« on: March 18, 2020, 06:34:29 PM »
index.php

Issue...

http://prntscr.com/rijci8

change

http://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js

to

https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js


I am sure they use a higher version of PHP like 7.2

This is my index.php

<?php
  header( 'Location: ./vam/index.php?lang=en' );
  exit();
?>

should i change anything there?

13
Support for Installation / Re: View issue
« on: March 18, 2020, 05:31:11 PM »
Change at the follow php ....

vam_header.php
vam_index_header.php


From:
<link rel="stylesheet" href="http://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">

to:
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">


The best thing you can do, change  in both PHP  everything entered with http to https.

Your page is SSL encrypted, original is in the VAM system no SSL available.

Sophie

Well, I made the changes and despite the website looks organized, there are some menu links that are no working. Like LogIn for example, when i click on it, I have no place to write user and pw.

-Another extra thing: No one can register as it saids (after clicking on Register) "Currently there is no vacancy in our company. Stay tuned for new recruitment process."

Thank u

14
Support for Installation / Re: View issue
« on: March 18, 2020, 05:15:16 PM »
Change at the follow php ....

vam_header.php
vam_index_header.php


From:
<link rel="stylesheet" href="http://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">

to:
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">


The best thing you can do, change  in both PHP  everything entered with http to https.

Your page is SSL encrypted, original is in the VAM system no SSL available.

Sophie

Thank you for your reply Sophie, I will see if I can do the changes and will let you know.

15
Support for Installation / Re: View issue
« on: March 18, 2020, 05:12:19 PM »
Hello,
Have you checked your php version is set to 7.0 or 7.1 in your hosting server settings.
It looks you have it set up to the wrong version

Thank you for your answer. I will investigate about that, I dont get a long with this things.
I will let you know soon!
Thank u!

Pages: [1] 2